Author Topic: Sample Apps not working  (Read 1707 times)


  • Guest
Sample Apps not working
« on: February 27, 2014, 04:49:50 pm »
Hello everyone,

I am a complete noob, so sorry if this question is too simple. When I bought DFSDK and obtained the sample apps, I immediately tried to simulate them in VS2013 (I had to upgrade the project files in order to do this) but while building the project, I received multiple errors and I received the message that the system cannot find the file specified (App.exe). Am I doing something wrong? I also have VS2010 and tried to do the same thing on that but got the exact same result (I redownloaded the sample apps so that the project files were not upgraded). I have also been waiting for my iPhone to be provisioned but it is taking quite a while... so in the mean time, I am trying to just simulate the sample apps. Thanks for reading and I appreciate any and all advice!



  • Guest
Re: Sample Apps not working
« Reply #1 on: February 28, 2014, 01:25:05 am »
Made sure you had DragonfireSDK installed in the right path, which is by default in C:\DragonfireSDK
Any better?


  • Guest
Re: Sample Apps not working
« Reply #2 on: February 28, 2014, 09:47:52 am »
Yes, I have made sure that it is in the right path, C:\DragonfireSDK but I am still getting the same problems


  • Jr. Member
  • **
  • Posts: 57
  • Karma: +0/-0
    • View Profile
Re: Sample Apps not working
« Reply #3 on: February 28, 2014, 04:06:35 pm »
Not sure this is helping _anything_ and I have encountered my shares of issues, but not this.

I have installed and run dragonfire+VC2010 (and further) on several PC's now, and procedure is always: install the VC2010 (or whatever version), install the dragonfire app, go to the myfirstapp project, open, convert to whatever version you are builing on and press F5 to debug-build/run.

Can you try running from within the visual studio (hit F5), when you state you get error not finding App.exe I'm thinking you try do something else. A debug .exe file should be myFirstapp.exe after initial build.

i understand your fustrations thoug, it is a bugger to not completing what you are doing.
Im no expert by far means, but if you realy cant coplete, record a video what you are doing, and share, Ill try help whatever I can.


  • Guest
Re: Sample Apps not working
« Reply #4 on: March 02, 2014, 10:03:45 pm »
I contacted support and talked to them about this problem. Since I am running VS2013, I needed to turn off "safe Exception Handling" in the Linker Settings in the project properties. I had no idea I had to do this, but now I can run the sample apps just fine. Thanks for your replies, guys, I really appreciate them.


  • Guest
Re: Sample Apps not working
« Reply #5 on: April 15, 2014, 10:13:24 am »

i have the same Problem. Debug Build does not work. Only Release build.
Is this normal?